Developers of decentralized exchange AirSwap discovered vulnerability in new smart contract

Developers of decentralized exchange AirSwap discovered vulnerability in new smart contract

The AirSwap development team reported a critical vulnerability in the new smart contract, which was reverted to an older version less than 24 hours after the problem was discovered.

The developers found a vulnerability in the new smart contract that could allow attackers to carry out swaps without a counterparty under certain conditions. The AirSwap team presented a possible solution for all potentially affected users in a publication on Medium:

“The vulnerability was present in the AirSwap system for less than 24 hours and affected only some AirSwap Instant users from noon on September 11 until early morning on September 12th. First, we identified a list of 20 vulnerable addresses matching this pattern, and quickly reduced it to 10 accounts that are currently at risk. ”

AirSwap notes that the vulnerable smart contract was reverted to an older version immediately after the problem was discovered, and that neither AirSwap Instant nor Trader products were affected by this vulnerability. The message from the development team also indicated nine Ethereum addresses that used a vulnerable smart contract.

Read This Now:   Putin announced the lack of investment in the oil market

Note that previously another decentralized 0x exchange also ran into problems. The developers of the protocol were forced to temporarily suspend the operation of the exchange, explaining this by a discovered vulnerability in the code of the smart contract.


Notice: ob_end_flush(): failed to send buffer of zlib output compression (1) in /home/gamefeve/bitcoinminershashrate.com/wp-includes/functions.php on line 5420

Notice: ob_end_flush(): failed to send buffer of zlib output compression (1) in /home/gamefeve/bitcoinminershashrate.com/wp-includes/functions.php on line 5420